source: subversion/applications/editors/merkaartor/INSTALL @ 13736

Last change on this file since 13736 was 12428, checked in by Łukasz Jernaś, 11 years ago

Small cleanup.

File size: 1.2 KB
Line 
1Prerequisites:
2* Working C++ compiler
3* Qt 4.3.3 or later development environment
4
5On (K)ubuntu Edgy it is sufficient to install the qt4-dev package
6to satisfy these requirements.
7
8Instructions
9
101. Change directory to the one in which you unpacked Merkaartor
11
12For example
13$ cd /home/me/src/Merkaartor-0.xx
14
152. Run qmake
16
17$ qmake Merkaartor.pro
18
192.1 Other qmake parameters for Merkaartor.pro
20
21PREFIX=<path>                   - base prefix for installation (unix only)
22TRANSDIR_MERKAARTOR=<path>      - where will the Merkaartor translations be installed
23TRANSDIR_SYSTEM=<path>          - where your global Qt translation directory is
24NODEBUG=1                       - release target
25NOUSEWEBKIT                     - disable use of WebKit (Yahoo adapter)
26
27see http://wiki.openstreetmap.org/index.php/Merkaartor_doc_0.12 for the complete list
28
29On (K)ubuntu this will probably pick up the qmake from Qt3 so
30you need to explicitly run the correct one : /usr/share/qt4/bin/qmake
31
323. Run your build tool, make for posix like systems, nmake for
33Windows C++ Build system
34
35$ make
36or
37$ nmake
38
394. If you are lucky, you'll find an executable in the
40binaries subdirectory. Otherwise mail a complete error log to
41bvh-osm@irule.be
42
43Bart Vanhauwaert
44
Note: See TracBrowser for help on using the repository browser.