source: subversion/applications/editors/osm-editor/qt3/README @ 34447

Last change on this file since 34447 was 1158, checked in by nick, 13 years ago

moved current version to qt3 directory in preparation for qt4

File size: 1.0 KB
Line 
1OpenStreetMap Editor
2====================
3
4Current version: osmeditor2. Build with "make osmeditor2".
5
6IMPORTANT
7=========
8
9If you get a linker error 'cannot find -lqt' change the following line:
10
11QTLIB = -lqt
12
13to
14
15QTLIB = -lqt-mt
16
17===============================================================================
18Notes:
19- Requires Qt3 and cURL to compile.
20- There are some real GPX files to play with. Look at the lats and longs
21therein and start osmeditor2 with the appropriate options.
22- Instructions on the OSM wiki.
23
24
25Loading SRTM height data
26------------------------
27
28If the NASA height files are present in a subdirectory (of the data
29you run the executable from) called "data", osmeditor will now draw
30contours for your current position.
31
32NASA height files can be obtained from
33
34  ftp://e0mss21u.ecs.nasa.gov/srtm/Eurasia/
35
36e.g. N51W001.hgt is the square with SW corner 51N, 1W.
37
38Building
39--------
40
41To build on Debian/sarge, one need to install the following dependencies:
42
43  libqt3-dev libcurl3-dev
44
45Nick Whitelegg
4626/03/06
Note: See TracBrowser for help on using the repository browser.