source: subversion/applications/utils/debian/control @ 17619

Last change on this file since 17619 was 17619, checked in by joerg, 10 years ago

remove ../lib from creation, correct error in dependency

File size: 2.9 KB
Line 
1Source: openstreetmap-utils
2Section: utils
3Priority: optional
4Maintainer: Joerg Ostertag <debian@ostertag.name>
5Build-Depends: debhelper (>> 3.7.2),
6        grass-dev,
7        libgeos-dev,
8        libfcgi-dev,
9        libmagick9-dev | libmagick10-dev ,
10        libmysql++-dev,
11        libpq-dev,
12        libshp-dev,
13        libshp-dev,
14        libxml2-dev,
15        pkg-config,
16        ant, ant-optional,
17        sun-java6-jdk,
18        libmysqlclient15-dev
19Standards-Version: 3.6.1
20
21Package: openstreetmap-utils
22Architecture: any
23Depends: perl,
24        python,
25        libshp1,
26        libmagick9 | libmagick10,
27        libfile-slurp-perl,
28        libdate-manip-perl,
29        postgresql-client,
30        java6-runtime|sun-java6-jre|sun-java6-jdk|openjdk-6-jre|openjdk-6-jdk|ia32-sun-java6-bin,
31        gpsbabel,
32        libshp1
33Recommends: gpsdrive,
34        mapnik,
35        openstreetmap-utils-import,
36        openstreetmap-utils-export,
37        openstreetmap-utils-filter,
38        openstreetmap-utils-lib
39Conflicts: gpsdrive-scripts, gpsdrive-utils,
40        osm2pgsql
41Description: OpenStreetmap Utilsopenstreetmap-osmosis
42 This Package contains some of the most usefull Utils
43 for working with OpenStreetMap
44
45
46Package: openstreetmap-utils-import
47Architecture: any
48Depends: perl,
49        python,
50        libshp1,
51        libmagick9 | libmagick10,
52        libfile-slurp-perl,
53        libdate-manip-perl,
54        postgresql-client,
55        java6-runtime|sun-java6-jre|sun-java6-jdk|openjdk-6-jre|openjdk-6-jdk|ia32-sun-java6-bin,
56        gpsbabel,
57        libshp1
58Recommends: gpsdrive,
59        mapnik
60Conflicts: gpsdrive-scripts,
61        osm2pgsql
62Description: OpenStreetmap Utils
63 This Package contains some of the most usefull Utils
64 for working with OpenStreetMap
65
66
67Package: openstreetmap-utils-filter
68Architecture: any
69Depends: perl,
70        python,
71        libshp1,
72        libmagick9 | libmagick10,
73        libfile-slurp-perl,
74        libdate-manip-perl,
75        postgresql-client,
76        java6-runtime|sun-java6-jre|sun-java6-jdk|openjdk-6-jre|openjdk-6-jdk|ia32-sun-java6-bin,
77        gpsbabel,
78        libshp1
79Recommends: gpsdrive,
80        mapnik
81Conflicts: gpsdrive-scripts,
82        osm2pgsql
83Description: OpenStreetmap Utils
84 This Package contains some of the most usefull Utils
85 for working with OpenStreetMap
86
87
88Package: openstreetmap-utils-export
89Architecture: any
90Depends: perl,
91        python,
92        libshp1,
93        libmagick9 | libmagick10,
94        libfile-slurp-perl,
95        libdate-manip-perl,
96        postgresql-client,
97        java6-runtime|sun-java6-jre|sun-java6-jdk|openjdk-6-jre|openjdk-6-jdk|ia32-sun-java6-bin,
98        gpsbabel,
99        libshp1
100Recommends: gpsdrive,
101        mapnik
102Conflicts: gpsdrive-scripts,
103        osm2pgsql
104Description: OpenStreetmap Utils
105 This Package contains some of the most usefull Utils
106 for working with OpenStreetMap
107
108
109#Package: openstreetmap-utils-lib
110#Architecture: any
111#Depends: perl,
112#       python,
113#       libshp1,
114#       libmagick9 | libmagick10,
115#       libfile-slurp-perl,
116#       libdate-manip-perl,
117#       postgresql-client,
118#       java6-runtime|sun-java6-jre|sun-java6-jdk|openjdk-6-jre|openjdk-6-jdk|ia32-sun-java6-bin,
119#       gpsbabel,
120#       libshp1
121#Recommends: gpsdrive,
122#       mapnik
123#Conflicts: gpsdrive-scripts,
124#       osm2pgsql
125#Description: OpenStreetmap Utils
126# This Package contains some of the most usefull Utils
127# for working with OpenStreetMap
128
Note: See TracBrowser for help on using the repository browser.