source: subversion/sites/rails_port/README @ 6554

Last change on this file since 6554 was 6554, checked in by tomhughes, 12 years ago

You need at least version 0.9.1 of the composite keys gem.

File size: 1008 bytes
Line 
1INSTALL
2=======
3
4* get rails working (http://www.rubyonrails.org/)
5
6* make your db (see db/README)
7
8* install ruby libxml bindings:
9
10   # sudo aptitude install libxml-ruby1.8 libxml-parser-ruby1.8
11
12* install primary keys plugin for active record (minimum version 0.9.1)
13 
14  # sudo gem install composite_primary_keys
15
16* make sure you have a MTA listening on localhost:25 if you want mail
17
18* script/server
19
20* thats it
21
22API CHANGES FOR EDITOR AUTHORS
23==============================
24
25See
26
27http://wiki.openstreetmap.org/index.php/REST#Changes_in_the_upcoming_0.4_API
28
29HACKING
30=======
31
32log in to your site (proably localhost:3000)
33
34create a user and confirm it
35
36you want to play with the API (probably at localhost:3000/api/0.4/node/create etc)
37
38Lots of tests are needed to test the API.
39
40Lots of little things to make the site work like the old one.
41
42Also see the 'rails_port' component for bugs:
43http://trac.openstreetmap.org/query?status=new&status=assigned&status=reopened&component=rails_port&order=priority
Note: See TracBrowser for help on using the repository browser.