Opened 11 years ago

Closed 11 years ago

#1008 closed defect (fixed)

tunnel rendering broken by smart-linecaps

Reported by: nomis Owned by: Jochen Topf
Priority: minor Milestone:
Component: osmarender Version:
Keywords: Cc: simon@…

Description

From reading the CSS tunnels are supposed to be rendered with a dashed line. However, since the smart-linecaps enable round linecaps for some of the segments and the dashes are less spaced than the linewidth, the round linecaps added to each of the dashes partially results in a continuous line with "bumps" (if you zoom into the svg a lot).

Disabling the smart linecaps seems to restore the intended behaviour.

Tromsø shows the problem: note how here are tunnels that are dashed as well as "dark gray" lines representing tunnels.

http://www.openstreetmap.org/?lat=69.66145&lon=18.95899&zoom=15&layers=0B0FTF

Change History (1)

comment:1 Changed 11 years ago by nomis

Resolution: fixed
Status: newclosed

I was mistaken about the intended behaviour. In fact the dashed lines should not be shown except for a small "outline".

Smart rendering for tunnels still might create more problems than it fixes, but not that urgent anymore. Closing as fixed.

Note: See TracTickets for help on using tickets.