Opened 11 years ago

Closed 11 years ago

#1102 closed defect (invalid)

Website error message upon search for Ludshott

Reported by: Daytona Owned by: Tom Hughes
Priority: minor Milestone:
Component: website Version:
Keywords: search error Cc:

Description

I couldn't find anywhere to report bugs, so I presume this is the place -

Website error message upon search for Ludshott from main page http://www.openstreetmap.org/ using Firefox 2.0.0.16 -

Search Results Close

Results from OpenStreetMap Namefinder

Error contacting gazetteer.openstreetmap.org: # /usr/lib/ruby/1.8/rexml/document.rb:90:in <<' /usr/lib/ruby/1.8/rexml/element.rb:868:in add' /usr/lib/ruby/1.8/rexml/child.rb:21:in initialize' /usr/lib/ruby/1.8/rexml/parent.rb:13:in initialize' /usr/lib/ruby/1.8/rexml/element.rb:59:in initialize' /usr/lib/ruby/1.8/rexml/element.rb:866:in new' /usr/lib/ruby/1.8/rexml/element.rb:866:in add' /usr/lib/ruby/1.8/rexml/element.rb:297:in add_element' /usr/lib/ruby/1.8/rexml/document.rb:97:in add_element' /usr/lib/ruby/1.8/rexml/parsers/treeparser.rb:33:in parse' /usr/lib/ruby/1.8/rexml/document.rb:205:in build' /usr/lib/ruby/1.8/rexml/document.rb:42:in initialize' /home/rails/app/controllers/geocoder_controller.rb:263:in new' /home/rails/app/controllers/geocoder_controller.rb:263:in fetch_xml' /home/rails/app/controllers/geocoder_controller.rb:121:in search_osm_namefinder' /home/rails/app/controllers/geocoder_controller.rb:21:in search' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:1158:in send' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:1158:in perform_action_without_filters' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/filters.rb:697:in call_filters' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/filters.rb:689:in perform_action_without_benchmark' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/benchmarking.rb:68:in perform_action_without_rescue' /usr/lib/ruby/1.8/benchmark.rb:293:in measure' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/benchmarking.rb:68:in perform_action_without_rescue' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/rescue.rb:199:in perform_action_without_caching' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/caching.rb:678:in perform_action' /var/lib/gems/1.8/gems/activerecord-2.0.2/lib/active_record/connection_adapters/abstract/query_cache.rb:33:in cache' /var/lib/gems/1.8/gems/activerecord-2.0.2/lib/active_record/query_cache.rb:8:in cache' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/caching.rb:677:in perform_action' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:524:in send' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:524:in process_without_filters' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/filters.rb:685:in process_without_session_management_support' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/session_management.rb:123:in process' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:388:in process' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/dispatcher.rb:171:in handle_request' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/dispatcher.rb:115:in dispatch' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/dispatcher.rb:126:in dispatch_cgi' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/dispatcher.rb:9:in dispatch' /var/lib/gems/1.8/gems/rails-2.0.2/lib/fcgi_handler.rb:101:in process_request' /var/lib/gems/1.8/gems/rails-2.0.2/lib/fcgi_handler.rb:149:in with_signal_handler' /var/lib/gems/1.8/gems/rails-2.0.2/lib/fcgi_handler.rb:99:in process_request' /var/lib/gems/1.8/gems/rails-2.0.2/lib/fcgi_handler.rb:77:in process_each_request' /var/lib/gems/1.8/gems/fcgi-0.8.7/lib/fcgi.rb:612:in each_cgi' /var/lib/gems/1.8/gems/fcgi-0.8.7/lib/fcgi.rb:609:in each' /var/lib/gems/1.8/gems/fcgi-0.8.7/lib/fcgi.rb:609:in each_cgi' /var/lib/gems/1.8/gems/rails-2.0.2/lib/fcgi_handler.rb:76:in process_each_request' /var/lib/gems/1.8/gems/rails-2.0.2/lib/fcgi_handler.rb:50:in process!' /var/lib/gems/1.8/gems/rails-2.0.2/lib/fcgi_handler.rb:24:in `process!' /home/rails/public/dispatch.fcgi:24 ... attempted adding second root element to document Line: Position: Last 80 unconsumed characters: Internal error, sorry.

Results from GeoNames?

No results found

Change History (1)

comment:1 Changed 11 years ago by Tom Hughes

Resolution: invalid
Status: newclosed

This was probably caused by me killing long running search threads to try and get the gazetteer back under control.

Note: See TracTickets for help on using tickets.