Ticket #1120 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Sometimes missing a way

Reported by: ColinMarquardt Owned by: koying
Priority: major Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

Since about two weeks, every once in a while (maybe 3 times until now, out of ~20 Merkaartor starts), I notice Merkaartor from SVN missing a way in the downloaded area. (It is a different way every time, not a specific one.) All the other ways connecting to the missing way are there, as are its nodes. "Download more" doesn't fix the problem, and downloading the current area again in the same editing session also doesn't. However, when I restart Merkaartor and load the same area again, then I had the way back in every case this happened to me.

I should have saved an MDC file I guess, will do that next time it happens to me.

Change History

comment:1 Changed 6 years ago by ColinMarquardt

Looking at your questions in #1055, I can say that for me, those roads were not especially long, maybe 1km in one case. What do you mean there by "specific roads, with some loading?"?

comment:2 Changed 6 years ago by koying

I guess I must have meant "Is it always the same roads which are not loading or is it random?"

comment:3 Changed 6 years ago by koying

  • Owner changed from cbro@… to koying
  • Status changed from new to assigned

I think I found the problem. I'd guess the roads you are missing are part of a relation, aren't they?

comment:4 Changed 6 years ago by koying

  • Status changed from assigned to closed
  • Resolution set to fixed

(In [10080]) FIX : Handle "NotYetDownloaded?" for Relations (closes #1120) FIX : Make "Referenced by relation" in Info dock working again FIX : Rebuild all way paths of a relation before painting

comment:5 Changed 6 years ago by ColinMarquardt

At least in the one instance I can remember offhand, that road was part of a relation, yes. Thanks for the fix.

Note: See TracTickets for help on using tickets.