Opened 11 years ago

Closed 11 years ago

#1141 closed defect (fixed)

Upload of a modified single GPX track node is not working

Reported by: osm@… Owned by: cbro@…
Priority: major Milestone:
Component: merkaartor Version:
Keywords: merkaator 0.11 Cc:

Description

Procedure:

  • open some GPX track
  • select a single node, either from the track or any other waypoint in that GPX
  • modify that node by adding some tags
  • upload
  • server reports error message "not found", the node is not uploaded

In fact this behavior is inconsistent to the way GPX track nodes are handled. If I create a road using the waypoints from the GPX track, the nodes becoming part of the road are copied to the dirty layer and are therefore also created as new nodes together with the new road. If I take a single node without making it part of a new road, and add some tags, this node should also be copied to the dirty layer before updating the node properties (This is actually the reason why the action fails: the dirty list contains just the update for a non-existent node). I often want to use single waypoints from the GPX track, e.g. for tagging node-only amenities like churches, ATMs, telephones etc., where I just made a waypoint out in the field. As a workaround I have to create a new node nearby and add the tags there.

I noticed this in Merkaator 0.11 for Windows, but the issue also exists in the current SVN build.

Change History (1)

comment:1 Changed 11 years ago by Chris Browet

Resolution: fixed
Status: newclosed

(In [10478]) FIX : Upload of a modified single GPX track node was not working anymore (fixes #1141)

Note: See TracTickets for help on using tickets.