Opened 11 years ago

Closed 10 years ago

#1161 closed defect (fixed)

Multipolygon: Untagged inner polygons don't render

Reported by: claudius.h@… Owned by: jburgess777@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

Wiki page on multipolygon relations states: "The inner way(s) may be left untagged."

Here is an example of this not working with mapnik with a building-multipolygon: http://www.openstreetmap.org/?lat=51.332022&lon=12.38288&zoom=18&layers=B000FTF

Change History (3)

comment:1 Changed 11 years ago by Skywave

Owner: changed from Tom Hughes to jburgess777@…

Bit of a duplicate of ticker #1113

comment:2 Changed 10 years ago by jburgess777@…

Owner: changed from jburgess777@… to jburgess777@…

comment:3 Changed 10 years ago by jburgess777@…

Resolution: fixed
Status: newclosed

Example looks OK now.

This was fixed when we started to import the data using the osm2pgsql --slim mode a few months ago. Since then, I have also fixed this case in the non-slim mode in r13470.

Note: See TracTickets for help on using tickets.