Opened 11 years ago

Closed 11 years ago

#1195 closed defect (fixed)

windows 0.12 beta3 crash on discard

Reported by: jpeterson@… Owned by: cbro@…
Priority: minor Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

Twice I've done some editing, gotten confused where I don't like the changes made and then I try to exit Merkartor.

Then Merkaartor prompts to discard the data, then crashes on clicking Discard.

Both times I've looked around and tried undo first and when that didn't help tried discard.

Because I don't want the changes, this doesn't lose data; but programs shouldn't segment fault.

Attached is a drwatson dump with the last two crashes on discard.

Further back in the log are more crashes of beta2. This was related to heavy scrolling with Yahoo on the screen; I haven't seen this yahoo scrolling crash in beta3

Attachments (2)

drwtns32_merkaartor.zip (130.5 KB) - added by jpeterson@… 11 years ago.
drwtns32_merkaartor_2.zip (44.0 KB) - added by jpeterson@… 11 years ago.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by jpeterson@…

Attachment: drwtns32_merkaartor.zip added

Changed 11 years ago by jpeterson@…

Attachment: drwtns32_merkaartor_2.zip added

comment:1 Changed 11 years ago by Chris Browet

Those crashes at closing time have always the same cause. Sometime during the session, a feature was deleted but there is still a pointer to it. When Merkaartor is doing the cleanup before closing, it crashes with a protection exception.

Unfortunately, the root cause, i.e. where was the feature deleted, is almost impossible to find out without a complete history of the session.

Bottom line: The only ways to correct this is to have an MDC just before the crash or for myself to experiment it while under debugging...

comment:2 Changed 11 years ago by Chris Browet

Resolution: fixed
Status: newclosed

This should be solved in 0.13 by the passage to QObject - guarded pointers for features

Note: See TracTickets for help on using tickets.