Opened 11 years ago

Closed 11 years ago

#1208 closed defect (fixed)

pt-br localisation not working

Reported by: Richard Owned by: richard@…
Priority: critical Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

Hi Ulf,

many thanks for providing potlatch. I've a question regarding the
translation of potlatch messages. According to
        http://wiki.openstreetmap.org/index.php/Template:Potlatch/Translation

translated messages should be integrated automatically when a new
version appears. However, when I start (on Linux), say, firefox under a
Brazilian Portuguese locale by
        LC_ALL="pt_BR.UTF-8" firefox

the program itself uses Brazilian Portuguese messages but Potlatch does
not, in spite of
        http://wiki.openstreetmap.org/index.php/Pt-br:Potlatch/Translation

being available for some time now. Am I missing something?

Ah - I think I see what's happening. system.capabilities.language in ActionScript expects pt-BR, but it's being fetched from the wiki as pt-br (lower case), possibly due to Mediawiki's strange capitalisation rules. I'll adapt the localisation script and let you know if it works. Sorry for the hassle.

cheers
Richard

Change History (1)

comment:1 Changed 11 years ago by Richard

Resolution: fixed
Status: newclosed

Will be fixed in 0.10d.

Note: See TracTickets for help on using tickets.