Opened 15 years ago

Closed 13 years ago

#123 closed defect (wontfix)

osm-editor Node.h needs to include cmath to compile osmeditor2

Reported by: Nick Owned by: steve@…
Priority: major Milestone:
Component: admin Version:
Keywords: Cc:

Description

Currently, building osmeditor2 on debian testing or fedora core 4 fails with:

make osmeditor2 c++ -w -g -I/usr/lib/qt-3.3/include/ curl-config --cflags -I/usr/local/include -Ijeeps-gpsbabel-1.2.7 -c -o osmeditor2.o osmeditor2.cpp Node.h: In member function ‘bool OpenStreetMap::Node::operator==(const OpenStreetMap::Node&)’: Node.h:92: error: ‘fabs’ was not declared in this scope make: * [osmeditor2.o] Error 1

Adding "#include <cmath>" to Node.h fixes this

Change History (2)

comment:1 Changed 14 years ago by jth@…

This looks old. Have you tried the new version for QT4?

comment:2 Changed 13 years ago by osm@…

Resolution: wontfix
Status: newclosed

osm-editor is probably dead these days.

Note: See TracTickets for help on using tickets.