Ticket #1232 (closed defect: invalid)

Opened 6 years ago

Last modified 5 years ago

Potlatch claims I'm not logged in after clicking edit tab after a long idle period

Reported by: smsm1 Owned by: tom@…
Priority: minor Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

Step to reproduce:

  1. Login to the openstreetmap.org web site.
  2. Don't do anything for a day
  3. navigate the map, and then click edit
  4. the website still thinks your logged in, however when the first edit is submitted to the server, you get an error message that says"You are not logged in, so the <point/way/relation> could not be saved.

Change History

comment:1 Changed 6 years ago by Richard

  • Owner changed from richard@… to tom@…
  • Priority changed from major to minor

Potlatch just uses User.authenticate, so this is a Rails issue rather than specifically a Potlatch one, I think.

comment:2 Changed 6 years ago by tom@…

I don't see how this can happen after three days at all.

I can see a possible mechanism where it could happen if you used Potlatch, then didn't use it for at least a week, then came back and tried to use it again. Whether you logged out and back in wouldn't matter but you would have to keep the same browser open for the whole period.

Is it likely that what I describe is what has happened to you?

comment:3 Changed 5 years ago by tom@…

  • Status changed from new to closed
  • Resolution set to invalid

Closing due to lack of response from submitter.

Note: See TracTickets for help on using tickets.