Opened 11 years ago

Closed 11 years ago

#1254 closed defect (fixed)

Osmarender fails to render subway_entrance (railway) in Barcelona

Reported by: admanero@… Owned by: osm@…
Priority: minor Milestone:
Component: osmarender Version:
Keywords: Cc:

Description

Look here:

http://www.openstreetmap.org/?lat=41.4438&lon=2.23895&zoom=17&layers=0B00FTF

if you edit the map you will see at the centre 3 points which have tags

railway, subway_entrace name=Pep ventura.

They are not rendered in either osmarender nor in mapnik.

For examples on which symbol to use for Metro subway (underground) stations in Barcelona and surrounding areas. Look here:

http://en.wikipedia.org/wiki/Barcelona_Metro http://en.wikipedia.org/wiki/Image:MetroBarcelona_L4_Logo.PNG

I have some knowledge in programming. I'll be happy to help fixing/implementig this. Look forward to guidance.

I assume it could be difficult to "fix" for each metro station network in every city/country as each city/country uses different logos, right?

Thanks

Change History (5)

comment:1 Changed 11 years ago by osm@…

Status: newassigned

Rendering the entrances to subway stations would indeed be good. But selecting the logo depending on the city is neither easy nor desirable. For the very same reason all bus stops have the same logo, independent of the carrier.

If you want to implement a rule to render the entrances, I'll be happy to help. That would also close the osmarender half of Ticket #1130 .

comment:2 Changed 11 years ago by osm@…

I found a list of logos for metros. It look quite hard to avoid a (possibly protected) variation of the letter "M" if you want to use that.

comment:3 Changed 11 years ago by admanero@…

"Protected variation of the letter M" Gosh sounds like we have to get legal counsel to use the symbol of the Metro of Barcelona on the mapping of Barcelona and surrounding areas. I would understand they wouldn't like it being used for other things but for what it was for what it was intended.

In any case, I have found this email cartografia@… in www.bcn.es about cartographic questions regarding the map of Barcelona. I should ask them ... But I don't think it should be a problem.

Regarding the implementation ... Looks like some png? graphics files have to be placed in

http://svn.openstreetmap.org/applications/rendering/osmarender6/symbols/ ?

or here?

http://trac.openstreetmap.org/browser/applications/share/map-icons/classic.small/transport ?

and then some rules have to be coded somewhere ... On some xml file? Where? Any guidance will be most welcome.

comment:4 Changed 11 years ago by osm@…

As far as I can tell the icon is a small svg file which goes to http://svn.openstreetmap.org/applications/rendering/osmarender6/symbols/subway.svg

To make it show up on the map you have to edit http://svn.openstreetmap.org/applications/rendering/osmarender6/osm-map-features-z<zoomlevel>.xml

Check the bus.svg and the rules for the bus stops for an example.

comment:5 Changed 11 years ago by osm@…

Resolution: fixed
Status: assignedclosed

Should be rendered as of r12408.

Note: See TracTickets for help on using tickets.