Opened 11 years ago

Closed 6 years ago

#1270 closed enhancement (fixed)

render construction=footway (was highway=construction colours)

Reported by: chriscf Owned by: steve8@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: Cc: HolgerJeromin

Description

Currently, all highway=construction are rendered in the same style - ideally the construction= tag should be used to choose an appropriate colour, such that motorways appear dashed blue, trunks dashed green, etc.

Change History (6)

comment:1 Changed 11 years ago by Skywave

I also have some railway=construction laying around, would be nice to see those rendered.

comment:3 Changed 10 years ago by steve8@…

Resolution: fixed
Status: newclosed

Should be resolved for all road types now

comment:4 Changed 7 years ago by HolgerJeromin

Cc: HolgerJeromin added
Resolution: fixed
Status: closedreopened
Summary: highway=construction coloursrender construction=footway (was highway=construction colours)

construction=footway is not rendered right now:

http://www.openstreetmap.org/browse/way/136003016 and surrounding

http://www.openstreetmap.org/browse/way/123262862 a footway bridge

thanks a lot

comment:5 Changed 7 years ago by HolgerJeromin

highway=proposed, proposed=footway is rendered, construction not. This is not logical :-)

comment:6 Changed 6 years ago by holgerjeromin

Resolution: fixed
Status: reopenedclosed

The Carto style fixed this ticket. Not sure if by design or "on error" :-)

Note: See TracTickets for help on using tickets.