Opened 11 years ago

Closed 11 years ago

#1275 closed defect (invalid)

Could not load gpx file

Reported by: rmikke Owned by: Tom Hughes
Priority: minor Milestone:
Component: utils Version:
Keywords: gpx upload Cc:

Description

Here is the error message while trying to upload GPX file Maybe something is wrong with the file, so I attach it to this ticket ===================================== It looks like your GPX file

rmikke.gpx

with the description

Janow Lubelski serwis rowerowy

  • Ukryj cytowany tekst -

and the following tags:

bicycle

service

shop

failed to import. Here's the error:

Entity: line 11:

/home/rails/config/initializers/libxml.rb:6

/var/lib/gems/1.8/gems/libxml-ruby-0.8.3/lib/libxml/parser.rb:36:in `call'

/var/lib/gems/1.8/gems/libxml-ruby-0.8.3/lib/libxml/parser.rb:36:in `xml_error_func_handler'

/home/rails/lib/gpx.rb:26:in `read'

/home/rails/lib/gpx.rb:26:in `points'

/home/rails/app/models/trace.rb:188:in `import'

/home/rails/lib/daemons/gpx_import.rb:21

/home/rails/lib/daemons/gpx_import.rb:15:in `each'

/home/rails/lib/daemons/gpx_import.rb:15

/var/lib/gems/1.8/gems/daemons-1.0.10/lib/daemons/application.rb:176:in `load'

/var/lib/gems/1.8/gems/daemons-1.0.10/lib/daemons/application.rb:176:in `start_load'

/var/lib/gems/1.8/gems/daemons-1.0.10/lib/daemons/application.rb:257:in `start'

/var/lib/gems/1.8/gems/daemons-1.0.10/lib/daemons/controller.rb:69:in `run'

/var/lib/gems/1.8/gems/daemons-1.0.10/lib/daemons.rb:139:in `run'

/var/lib/gems/1.8/gems/daemons-1.0.10/lib/daemons/cmdline.rb:105:in `call'

/var/lib/gems/1.8/gems/daemons-1.0.10/lib/daemons/cmdline.rb:105:in `catch_exceptions'

/var/lib/gems/1.8/gems/daemons-1.0.10/lib/daemons.rb:138:in `run'

lib/daemons/gpx_import_ctl:20

=====================================

Attachments (1)

rmikke.gpx (3.7 KB) - added by rmikke 11 years ago.
GPX file that fails to upload

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by rmikke

Attachment: rmikke.gpx added

GPX file that fails to upload

comment:1 Changed 11 years ago by rmikke

Component: adminutils
Priority: majorminor

Wait a moment, the most probable reasin is that I have spoiler boundaries tag when adding rimestamp to trackpoints... I'll check this tonight.

comment:2 Changed 11 years ago by rmikke

Resolution: invalid
Status: newclosed

That was that.

I have just replaced all '/>' with:

<time>some time tag</time> </trkpt>

and I haven't noticed that there is one more "singular" XML tag, not only <trkpt/>...

Note: See TracTickets for help on using tickets.