Ticket #1290 (closed defect: wontfix)

Opened 5 years ago

Last modified 7 months ago

Way path and label path do not match

Reported by: chriscf Owned by: osm@…
Priority: minor Milestone:
Component: tilesathome Version:
Keywords: Cc:

Description

http://www.openstreetmap.org/?lat=51.51129&lon=-3.19523&zoom=17&layers=0B00FTF

A glance at the editing view shows that the label path matches that of the way, whereas the rendered way has been bezier-curved at various points. As a result, the two do not match.

Change History

comment:1 Changed 5 years ago by osm@…

  • Status changed from new to assigned

Good catch. Patch to use the bezierhinted path for lable placement is of cource welcome.

comment:2 Changed 5 years ago by osm@…

  • Owner changed from osm@… to osm@…
  • Status changed from assigned to new
  • Component changed from osmarender to tilesathome

The problem is that bezierhinting is done AFTER the xml-to-svg conversion with osmarender. Therefore this is not really an osmarender bug (and probably quite hard to fix).

comment:3 Changed 7 months ago by iandees

  • Status changed from new to closed
  • Resolution set to wontfix

Cleaning aging tickets.

Note: See TracTickets for help on using tickets.