Opened 11 years ago

Closed 10 years ago

#1318 closed defect (wontfix)

Docks are growing when selecting nodes/ways

Reported by: richardbrinkman@… Owned by: Chris Browet
Priority: major Milestone:
Component: merkaartor Version:
Keywords: Cc: andrea@…

Description

My layout of the MainWindow? is as follows: On the left I have the Layers dock and the Properties dock, in the middle the map and on the right the Info dock and the Undo dock.

With this layout I have the weird behaviour that every way or node that I select causes the left panel (with the Layers and Properties dock) to grow by half a centimeter leaving less room for the map. The panel cannot be made smaller by dragging the (right) border (it can be made bigger though). I guess that the minimum size of one of the docks is increased each time you select a way/node, but since I'm not a C++ expert this is just my guess.

This behaviour started after the templatized tags. Before, I had not have the problem.

Attachments (3)

before.jpg (117.1 KB) - added by richardbrinkman@… 11 years ago.
afterfirstselection.jpg (144.0 KB) - added by richardbrinkman@… 11 years ago.
aftertenselections.jpg (163.1 KB) - added by richardbrinkman@… 11 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 11 years ago by Chris Browet

Strange, I don't see this behaviour.

Could you state your OS/Qt version, please.

Also, screenshots would be nice.

Changed 11 years ago by richardbrinkman@…

Attachment: before.jpg added

Changed 11 years ago by richardbrinkman@…

Attachment: afterfirstselection.jpg added

Changed 11 years ago by richardbrinkman@…

Attachment: aftertenselections.jpg added

comment:2 Changed 11 years ago by richardbrinkman@…

qt-4.4.3-1.fc9.x86_64 (Fedora 9) Made with /usr/bin/qmake-qt4 -unix TRANSDIR_MERKAARTOR=/home/brinkman/usr/share/merkaartor TRANSDIR_SYSTEM=/usr/share/qt4/translations OSMARENDER=1 NODEBUG=1 NOWEBKIT=1GEOIMAGE=1-o Makefile Merkaartor.pro

I uploaded 3 screenshots: before.jpg: before any road was selected afterfirstselection.jpg: after I selected a single road aftertenselections.jpg: after I selected 10 roads (one at a time)

comment:3 Changed 11 years ago by Chris Browet

Owner: changed from cbro@… to Chris Browet
Status: newassigned

I can reproduce on Linux but not on Windows. QT issue?

comment:4 Changed 11 years ago by Chris Browet

Actually, the problem seems to exists on 0.12, too, before the templates.

I'm baffled that nobody reported this before...

comment:5 Changed 11 years ago by Chris Browet

Resolution: wontfix
Status: assignedclosed

It looks like the problem is specific to the "plastique" Qt style, which is the default on Linux, on recent Qt version.

Executing merkaartor with, e.g., the "cleanlooks" style, do not exhibit the problem.

To do so, run "merkaartor -style cleanlooks".

We can just hope the problem will be solved on future releases of Qt.

comment:6 Changed 10 years ago by aboaboit

Cc: andrea@… added

Looked at the QT buglist and saw nothing applicable, so I submitted a new entry (with additional info pointing back here)

comment:7 in reply to:  5 Changed 10 years ago by aboaboit

Resolution: wontfix
Status: closedreopened

Replying to koying:

It looks like the problem is specific to the "plastique" Qt style, which is the default on Linux, on recent Qt version.

Executing merkaartor with, e.g., the "cleanlooks" style, do not exhibit the problem.

0.14 here and I can reproduce the problem even with cleanlooks style: select a region, then click a road outside that region. From that point on, it goes on growing.

comment:8 Changed 10 years ago by aboaboit

Forgot to say, I had "custom qt style: oxygen" ticked. It doesn't happen without.

comment:9 Changed 10 years ago by Chris Browet

Could you state your Qt version, please.

As said before, this is a Qt version specific bug (< 4.5.1, I think)

comment:10 in reply to:  9 Changed 10 years ago by aboaboit

Resolution: wontfix
Status: reopenedclosed

Replying to Koying:

Could you state your Qt version, please. As said before, this is a Qt version specific bug (< 4.5.1, I think)

You're right: the first test (when I wrote the report) was with 4.5.0. Weird part was that having a custom style exposed the bug. Tried again with 4.5.2 from QT SDK 2009.03 and I can't reproduce it anymore.

Case close, sorry for the noise and congrats for the great program :)

Note: See TracTickets for help on using tickets.