Opened 11 years ago

Closed 11 years ago

#1333 closed enhancement (fixed)

Allow canvas background to be set from a style

Reported by: Colin Marquardt Owned by: Chris Browet
Priority: minor Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

I thought I had filed this ticket before, but can't find it... so here it goes.

I just committed a style called Lighting which displays ways with the lit=yes tag in a yellow color. In order to create the illusion of a "night mode", it would be nice if the style could set the color of the canvas background. Right now, this is a global user setting.

Change History (4)

comment:1 Changed 11 years ago by Chris Browet

Resolution: fixed
Status: newclosed

(In [12293]) ADD : Allow canvas background to be set from a style. Background color is still overridable in the global preferences. (closes #1333)

comment:2 Changed 11 years ago by Colin Marquardt

Resolution: fixed
Status: closedreopened

Thanks very much, I updated Lighting.mas accordingly. There is one problem with it however: when you had Lighting selected and switch back to another style which doesn't have the background color defined, it stays like it was. Is this the intended behavior? If so, then I'd need to add the background setting to all of the styles. No problem, but it would not cover styles people use only locally.

comment:3 Changed 11 years ago by Chris Browet

The truth is I just didn't thought about this case.

Definitely, it should revert to the pref defined background.

comment:4 Changed 11 years ago by Chris Browet

Resolution: fixed
Status: reopenedclosed

(In [12311]) FIX : revert to preferences background when switching style and no background is defined in the new style (fixes #1333)

Note: See TracTickets for help on using tickets.