Opened 11 years ago

Closed 11 years ago

#1354 closed defect (fixed)

GPX file fails to upload to OSM, complaining about missing <time> tags

Reported by: Andrew Gee Owned by: dsilvers@…
Priority: major Milestone:
Component: utils Version:
Keywords: gpx upload Cc:

Description

I use Nokia Sportstracker to take traces with my N95 phone. I have been using this method for some time now, successfully uploading traces to the server.

I made a few traces today and wanted to upload these. When I attempted to, it failed and sent me an email saying "Found no good GPX points in the input data. At least 75% of the trackpoints lacked a <time> tag."

I have checked my gpx file and can confirm there are time tags there, and in the correct format.

I have attached one of the gpx files in question.

Attachments (1)

W20081121133958.gpx (43.8 KB) - added by Andrew Gee 11 years ago.
Bad GPX file

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by Andrew Gee

Attachment: W20081121133958.gpx added

Bad GPX file

comment:1 Changed 11 years ago by Andrew Gee

Owner: changed from Tom Hughes to dsilvers@…

comment:2 Changed 11 years ago by Tom Hughes

Looks like the problem with this one is that it has no timezone indication at all (which is valid).

comment:3 Changed 11 years ago by Andrew Gee

Through attempting to play around with things, I ended up deleting a gpx file, from my profile, that I successfully uploaded the other day. So I just tried to re-upload that trace, which resulted in the same error, indicating this is a recently introduced bug, I would have thought.

comment:4 Changed 11 years ago by Andrew Gee

I have actually narrowed this down to a problem with the seconds part of the time tag. The application I use for my traces, sportstracker, included milliseconds after the seconds, after a decimal point. These used to be fine in uploading to OSM, but now they're not.

I managed to upload a trace by removing all the milliseconds by hand, from the gpx file.

Is having the milliseconds in the time tag valid, or is this a problem with the sportstracker software I use?

Thanks

comment:5 Changed 11 years ago by Tom Hughes

It is valid yes, although a quick reading of the xsd:dateTime specification might lead you to believe otherwise as the main syntax shown does not provide for a fractional second. It references ISO 8601 however, and that does allow for a fractional component. In addition one of the examples in the xsd:dateTime spec does have a fractional component.

comment:6 Changed 11 years ago by dsilvers@…

Status: newassigned

I believe this to be fixed in r12034 -- This ticket can be resolved once the fix is deployed.

comment:7 Changed 11 years ago by dsilvers@…

Resolution: fixed
Status: assignedclosed

The fix has been deployed

Note: See TracTickets for help on using tickets.