Ticket #1366 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Revert function not functioning

Reported by: Ezhick Owned by: richard@…
Priority: major Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

While trying to undo changes made by other user I discovered that the revert function is not working properly. For example I reverted changes made to ways ID 9891826, 24673690, 24673678. But they didn't change. At the same time the author of the way change, and the revert function is proposing an older recovery point to revert to.

Change History

comment:1 Changed 5 years ago by Richard

Would be grateful if you could provide an /edit URL for this area - otherwise it takes me about half an hour of scratting around (I'm using a shit Internet connection) to find where you're talking about. Thanks.

If you could provide details of what changed, at what time, and what you were expecting to see, that would also be helpful.

comment:2 Changed 5 years ago by Ezhick

The url  http://openstreetmap.org/edit?lat=55.75562&lon=37.58796&zoom=15

You can see 2 primary roads that are messed up (they are triangle, but must be straight), a dridge which is not on its place and so on. Many secondary roads on the right side are also messed up.

They were all change by user alkmay jn Njvember, 25

Yesterday evening I used the revert function to restore them to the original state. I waited till the data was saved, logged off. When later I downloaded the data with josm I so the mess was still there. I waited till the morning, logged in with potlatch - the mess is in place, and the author of the changes -s not alkmay, but the author of the changes I reverted to.

comment:3 Changed 5 years ago by Richard

Ok, thanks.

When I revert the changes, save them, then reload Potlatch, it looks as it should to me - I can't see anything that isn't working as expected. What am I missing?

One thing to note is that Potlatch's "revert" functionality only notices changes if the way itself has been touched, as well as the constituent nodes. Potlatch always updates the way when the constituent nodes are moved, but other editors don't. So if these errors have been caused by someone using another editor, they may not show up in the pop-up menu.

comment:4 Changed 5 years ago by Ezhick

Strange... I did it yesterday and today morning and it didn't save. And now I see the reverted ways you reverted... I'll try to revert all the rest, but looks like the problem is not showing any more...

comment:5 Changed 5 years ago by Ezhick

  • Status changed from new to closed
  • Resolution set to fixed

Everything saved. Hell knows why it happend... Thanx for your help.

comment:6 follow-up: ↓ 7 Changed 5 years ago by Richard

Heh, no problem. Glad it's working.

One thing to note: when you revert a way, the connection with other ways may not be working any more. (In other words, there might be two separate nodes at the 'junction', rather than one common one.) I'll look into this but you may need to fix it manually for now.

comment:7 in reply to: ↑ 6 Changed 5 years ago by Ezhick

Ok, I'll check this out.

Note: See TracTickets for help on using tickets.