Opened 9 years ago

Closed 9 years ago

#1431 closed defect (duplicate)

Can't delete way+nodes with 0.6 (JOSM)

Reported by: stevens Owned by: tom@…
Priority: major Milestone: OSM 0.6
Component: api Version:
Keywords: Cc:

Description

I tried deleting a way through JOSM on the 0.6 API
This was with josm (1137):

The upload seemed to fail on closing the changeset. The output from JOSM is below. It looks like the server is closing the connection (which is why I am filing this against the API vs JOSM, feel free to move it if I am mistaken)

I also tried manually committing changeset 55 through wget but was unable.

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1137
Node Kind: directory
Last Changed Author: framm
Last Changed Rev: 1137
Last Changed Date: 2008-12-15 00:45:00 +0100 (Mon, 15 Dec 2008)

download: http://api06.dev.openstreetmap.org/api/0.6/map?bbox=-0.02451658203125,51.396236708984375,-0.01902341796875,51.398983291015625
Defaults for osm-server.version differ: 0.6 != 0.5
upload to: http://api06.dev.openstreetmap.org/api/0.6/changeset/create...Defaults for osm-server.version differ: 0.6 != 0.5
connected
got return: 200 with id 55
Defaults for osm-server.version differ: 0.6 != 0.5
Defaults for osm-server.version differ: 0.6 != 0.5
the document:

<osmChange version="0.6" generator="JOSM">
<delete version="0.6" generator="JOSM">
<way id="28501060" version="1" changeset="55" />
<node id="313087921" version="1" changeset="55" />
<node id="313087922" version="1" changeset="55" />
<node id="313087923" version="3" changeset="55" />
</delete>
</osmChange>

Defaults for osm-server.version differ: 0.6 != 0.5
upload to: http://api06.dev.openstreetmap.org/api/0.6/changeset/55/upload...connected
backing off for 10 seconds...retrying (9 left)
Defaults for osm-server.version differ: 0.6 != 0.5
upload to: http://api06.dev.openstreetmap.org/api/0.6/changeset/55/close...Defaults for osm-server.version differ: 0.6 != 0.5
connected
Defaults for osm-server.version differ: 0.6 != 0.5
upload to: http://api06.dev.openstreetmap.org/api/0.6/changeset/55/close...Defaults for osm-server.version differ: 0.6 != 0.5
connected
java.lang.RuntimeException?: Unexpected end of file from server java.net.SocketException?

at org.openstreetmap.josm.io.OsmServerWriter?.stopChangeset(OsmServerWriter?.java:453)
at org.openstreetmap.josm.io.OsmServerWriter?.uploadOsm(OsmServerWriter?.java:155)
at org.openstreetmap.josm.actions.UploadAction?$2.realRun(UploadAction?.java:152)
at org.openstreetmap.josm.gui.PleaseWaitRunnable?.run(PleaseWaitRunnable?.java:84)
at java.util.concurrent.ThreadPoolExecutor?$Worker.runTask(ThreadPoolExecutor?.java:665)
at java.util.concurrent.ThreadPoolExecutor?$Worker.run(ThreadPoolExecutor?.java:690)
at java.lang.Thread.run(Thread.java:803)

Caused by: java.net.SocketException?: Unexpected end of file from server

at sun.net.www.http.HttpClient?.parseHTTPHeader(HttpClient?.java:714)
at sun.net.www.http.HttpClient?.parseHTTP(HttpClient?.java:585)
at sun.net.www.http.HttpClient?.parseHTTPHeader(HttpClient?.java:712)
at sun.net.www.http.HttpClient?.parseHTTP(HttpClient?.java:585)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:966)
at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:379)
at org.openstreetmap.josm.io.OsmServerWriter?.stopChangeset(OsmServerWriter?.java:402)
... 6 more

Change History (1)

comment:1 Changed 9 years ago by ivansanchez@…

  • Resolution set to duplicate
  • Status changed from new to closed

I think this is already fixed in r13603. See #1567

Note: See TracTickets for help on using tickets.