Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#1439 closed defect (invalid)

unicode input broken

Reported by: firespeaker Owned by: richard@…
Priority: major Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

When I enter unicode (utf-8) characters into the map editor, it converts it into latin-1 in real time. It also displays already-input unicode characters with spaces between them, and doesn't allow me to copy/paste them.

Attachments (1)

screenshot.2009-01-04.01.png (115.3 KB) - added by firespeaker 11 years ago.
Demonstrates incorrect behaviour of unicode.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by firespeaker

Demonstrates incorrect behaviour of unicode.

comment:1 Changed 11 years ago by firespeaker

Component: appletpotlatch (flash editor)
Owner: changed from steve@… to richard@…

comment:2 Changed 11 years ago by Richard

Resolution: invalid
Status: newclosed

This is a very very very very longstanding problem with Adobe Flash Player on Linux. See the Potlatch FAQ on the OSM wiki and look for Adobe bug FP-40. We can't do anything until Adobe fixes their broken code.

comment:3 Changed 10 years ago by emj

Workaround from adobe bug page, Press ctrl+åäö and it will work.

Duplicate of: http://trac.openstreetmap.org/ticket/1020

Note: See TracTickets for help on using tickets.