Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1448 closed defect (fixed)

Draging the map takes too long to redraw

Reported by: Beart Owned by: cbro@…
Priority: major Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

When draging the map redrawing takes quite a time (more than 10 seconds in my case) so it is far from interactive.

This has been reported on the mailing list and a patch has been submitted by Łukasz Jernaś. This patch has not been applied in SVN yet and in the meanwhile the patch is conflicting with the current version of Interaction.cpp.

Attachments (2)

Interaction.patch (369 bytes) - added by Beart 10 years ago.
patch from Łukasz Jernaś (posted on the mailing list)
NewInteraction.patch (378 bytes) - added by Beart 10 years ago.
Łukasz' patch for the current revision with slight performance improvement according to mailing list discussion

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by Beart

Attachment: Interaction.patch added

patch from Łukasz Jernaś (posted on the mailing list)

Changed 10 years ago by Beart

Attachment: NewInteraction.patch added

Łukasz' patch for the current revision with slight performance improvement according to mailing list discussion

comment:1 Changed 10 years ago by Chris Browet

Resolution: fixed
Status: newclosed

(In [13051]) FIX : Add NVIDIA_HACK in Config.pri to (hopefully) help with Nvidia slowdowns. (fixes #1448)

comment:2 Changed 10 years ago by Beart

Thanks for that fix. The actual change in Interaction.cpp does now use invalidate(true, true) instead of the more minimal but as effective invalidate(true, false). Is that intentional?

comment:3 Changed 10 years ago by Chris Browet

No, I used Łukasz original patch rather than the more recent one. Remember I cannot reproduce myself.

if (true, false) is good enough, I'll use that.

comment:4 Changed 10 years ago by BearT

Thanks again. Łukasz confirmed that the more minimal version works even better and I could not find any changes. It's at least as fast as the (true, true) version.

As I see in the timeline the patch has been applied, so this item should now truly be closed.

Note: See TracTickets for help on using tickets.