Opened 11 years ago

Closed 11 years ago

#1449 closed defect (fixed)

Resolve all Relations not working

Reported by: richardbrinkman@… Owned by: Chris Browet
Priority: major Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

On the download page there is a checkbox "Resolve all relations". This is supposed to download all the relations in the selected area. However, it only downloads those relations for which all the members are in the area. If, for instance, you have a large cycle route crossing half the country, you will not be able to see/edit that relation, unless you download half the country. I really would like that all the roads of any relation that crosses/starts/ends in the downloaded area are downloaded. (Or if that is to much download at once, a way to show/edit a partially downloaded relation).

Change History (4)

comment:1 Changed 11 years ago by Chris Browet

Actually, "Resolve all relations" is supposed to download all the members of the relations that intersects (API-wise) with the bounding box being downloaded, e.g. if you download an area with part of a country border, it should download the complete border (assuming it is a relation, of course).

Is it how you understand it? If so, could you provide an example where it does not work.

Note that the API do not download a relation if the requested bounding box is completely inside the relation.

comment:2 Changed 11 years ago by richardbrinkman@…

Take for instance the LF3 cycleway from Maastricht to Arnhem (well it has been mapped uptill Nijmegen, yet). If I download the piece near Nijmegen (http://openstreetmap.org/?lat=51.81036&lon=5.87083&zoom=15&layers=00B0FTF, make sure to view the Cycleway map to see the LF3), only that piece is being downloaded. I don't get the other roads nor do I get the bounding box that normally surrounds the ways in a relation. My guess is that only ways that intersect the downloading area are downloaded in full, not relations that intersect.

comment:3 Changed 11 years ago by Chris Browet

Owner: changed from cbro@… to Chris Browet
Status: newassigned

Err... I'm completely wrong.

Actually "Resolve all relations" was meant to download relations within relations. By implementing this, I flawed the code completely.

comment:4 Changed 11 years ago by Chris Browet

Resolution: fixed
Status: assignedclosed

(In [13134]) FIX : Make "Resolve Relations" work as intended (fixes #1449)

Note: See TracTickets for help on using tickets.