Opened 11 years ago

Closed 10 years ago

#1506 closed defect (invalid)

Create roundabout sometimes freezes and crashes M.

Reported by: BearT Owned by: cbro@…
Priority: minor Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

The "Create > Roundabout" option sometimes (two of three tries) crashes Merkaartor. It first freezes M. and then M. is closed. The first time the freeze took quite long (about 10 minutes), the second time it crashed and closed after a few seconds freezing. One time the roundabout was created as expected.

I'm sorry I can't give any instructions to reproduce it, but maybe the code should be overlooked again. The crash happens on the actual creation of the roundabout, when the streets are added. I have a gpx track of the roundabout in the background, so I'm not doing WMS mapping.

Bug found in r13235 under Ubuntu Linux.

Change History (4)

comment:1 Changed 10 years ago by Chris Browet

Could you try to reproduce with a debug build and provide me with a backtrace, please

comment:2 Changed 10 years ago by BearT

Sorry, I haven't checked for replies here. I'll try to reproduce the error on a debug build as soon as I'm able to build Merkaartor again. (see #1659)

comment:3 Changed 10 years ago by BearT

Priority: majorminor

I tried to reproduce the error on a debug build (r14265) and could not reproduce the rror. Created tons of roundabouts and none failed. I've also checked on a release build about one week ago, there Merkaartor crashed only once after creating about 20 roundabouts. This is significantly less than at the time I reported this.

I've checked on a 64bit machine under Ubuntu Intrepid now. I first saw this bug on a 32bit Ubuntu machine which I have access to this weekend. I'll try again on this very same computer, but until then I lower the priority of this bug.

comment:4 Changed 10 years ago by beart

Resolution: invalid
Status: newclosed

I could not reproduce this error with the current version of Merkaartor on the very same computer I encountered these crashes when I reported them.

Note: See TracTickets for help on using tickets.