Opened 11 years ago

Closed 11 years ago

#1519 closed enhancement (duplicate)

Clean up relation drop down list, let user decide on sorting order

Reported by: Svenr Owned by: richard@…
Priority: major Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

The whole relation editor part looks a bit unordered to me. I've used it a bit and until now have not seen a meaningful sorting order in the drop down list.

Additionally, this list grows quite long if I scroll around the map in potlatch, as it gathers more and more relations that got into view or were close enough to the viewport to be loaded. In dense cities it'll be no surprise if this list fills the whole screen with mostly visually unordered garbage.

I'd suggest some things like this:

  • clean up the printed text into a visually ordered table. Columns might work wonders.
  • let user decide which relation tag should be used for ordering.
  • let user decide which relation tags should be shown at all.
  • as the usage of relations grows, consider using a multi-step-selection with the relation type as the first choice, thus splitting the long list of completely mixed puropses (multipolygons, routes, etc.) into shorter ones for a single purpose.

Change History (1)

comment:1 Changed 11 years ago by Richard

Resolution: duplicate
Status: newclosed

This is essentially a duplicate of #1383. I agree that there needs to be some sort of ordering and such like, but don't envisage making any major changes until a future version of Potlatch can use Adobe's pre-rolled UI components - I don't particularly want to write an entire scrollable, hierarchical menu component myself!

Note: See TracTickets for help on using tickets.