Opened 10 years ago

Closed 10 years ago

#1528 closed defect (fixed)

merkaartor hangs after mouse-hovering a relation

Reported by: azog Owned by: cbro@…
Priority: major Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

Steps to reproduce:

  1. Download with OSM-link http://openstreetmap.org/?lat=49.60564&lon=11.03757&zoom=16&layers=B000FTF
  2. Move your mouse over the boundary of the relation with the forest (rel_19883)
  3. Merkaartor hangs for at least 5 seconds

I am using Merkaartor 0.12+svn13050-1 from Debian experimental and tested this also with the svn-version of 2009-01-20.

Attachments (1)

Change History (5)

comment:1 Changed 10 years ago by Chris Browet

I cannot reproduce.

Could you please attach a screenshot.

comment:2 Changed 10 years ago by eMerzh

I have it too with the svn version on kubuntu 8.10 / kde 4.2

nothing strange on tty...

comment:3 Changed 10 years ago by azog

I wrote a mail to the list yesterday, but it seems, that it got stuck in the moderator-queue:

I wrote a patch while searching for the cause of this problem, which adds 3 small preferences:

  • Show info on hover
  • Show parents on hover
  • Outline the relation's bounding box on hover

The last two can fix the problem if checked false.

comment:4 Changed 10 years ago by Chris Browet

Resolution: fixed
Status: newclosed

(In [13791]) FIX : Painting slowdowns (+ memory consumption) when relations are involved (fixes #1528)

Note: See TracTickets for help on using tickets.