Opened 11 years ago

Closed 11 years ago

#1554 closed defect (fixed)

addr:housenumber only works on second entry

Reported by: geltmar Owned by: richard@…
Priority: major Milestone:
Component: potlatch (flash editor) Version:
Keywords: housenumber, address Cc:

Description

Inserting addresses with potlatch works great. postcode, city, street ... is saved correctly. addr:housenumber can be inserted as well. But clicking somewhere else (i.e. deselecting the edited object) and clicking back on the object, shows: NO housenumber. inserting it again... it will be saved.

Change History (4)

comment:1 Changed 11 years ago by geltmar

Priority: minormajor

Did a few more tests. Sometimes you have addr:postcode saved with an object. You insert addr:housenumber and then addr:postcode is deleted?/not shown? I inserted quite a few addresses yesterday. Housenumbers showed up in a renderer today. clicking on an object with a renderd housenumber in potlatch... shows NO housenumber of that object. So it is possible, that my former description is wrong... maybe it is saved in the database, but not properly retrieved, to be edited in potlatch.

comment:2 Changed 11 years ago by PHerison

I can confirm the problem. I couldn't determin a realtion between entered address-tag and deleted address-tag. I seems to me, that a random address-tag is thrown away for a new one entered. Or sometimes no tag is deleted. It seems that the defect is only related to addr:*-Tags. Other tags of the node (amenity, shop aso.) won't be deleted. Using JOSM works as expected. Example: http://www.openstreetmap.org/browse/node/354923428/history The error is permanent and can be reproduced everytime.

comment:3 Changed 11 years ago by Pouletic

Second confirmation here. This was driving me batty today, so I'm glad to see I'm not imagining things. It's always an addr:* tag that gets lost-usually seems to be housenumber, but i think street was lost a few times as well.

comment:4 Changed 11 years ago by Richard

Resolution: fixed
Status: newclosed

Fixed (on next deploy) - it was an issue with the autocomplete menu. Thanks for spotting.

Note: See TracTickets for help on using tickets.