Opened 10 years ago

Closed 10 years ago

#1566 closed defect (fixed)

[patch] Black Tile encountered at lib/Tileset.pm line 1364

Reported by: stephankn Owned by: osm@…
Priority: major Milestone:
Component: osmarender Version:
Keywords: Cc:

Description

SVN Revision: 13579

Rasterizer=Batik produces black tiles.

reproduce with tilesgen.pl xy 1 1 17

I suppose this is caused by an attribute used that is not specified in SVG. I have attached a patch that removes the error.

I can not say if it is the way it's intended to be rendered. That's why I did not submit it.

osm-map-features-z17.xml:3920

.housenumber-left has text-anchor:left

According to SVG specification this is an invalid value for this property. Should it be "start"?

Attachments (1)

1566_black_tile.patch (413 bytes) - added by stephankn 10 years ago.
patch changing left into start

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by stephankn

Attachment: 1566_black_tile.patch added

patch changing left into start

comment:1 Changed 10 years ago by osm@…

Resolution: fixed
Status: newclosed

Fixed by bobcare in r13589.

Note: See TracTickets for help on using tickets.