Opened 9 years ago

Closed 8 years ago

#1570 closed enhancement (fixed)

rendering of highway=platform; railway=platform

Reported by: itschytoo Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: rules, highway, platform, railway Cc: ajoessen

Description

I'm heavily using highway=platform to model larger bus_stop-platforms.

This is in analogus to railway=platform.

Both are not currently rendered on the map.

I propose to have these two combinations rendered like highway=living_street (i.e. darker grey).

This should be done for way, area and node (in the last case just a small circle).
Please also display the contents of the "ref="-tag, as it would contain the platforms number (like "ref=9 3/4").

Thank you.

Attachments (1)

add_platform_area.patch (490 bytes) - added by David Paleino 8 years ago.
Add rendering for railway=platform + area=yes

Download all attachments as: .zip

Change History (17)

comment:1 Changed 9 years ago by steve8@…

Can you provide URLs for each example so I can have a look?

comment:3 in reply to: ↑ 2 ; follow-up: Changed 9 years ago by itschytoo

Sorry for that mess. I will retry...
Please have a look at #1571, same proposal for osmarender. Osmarender already renders the platform, and I think they do quite well.
Go here for examples:
way+node
way
way
way+area, looks crap because of osmarenders zoomlevel cap at 17

comment:4 in reply to: ↑ 3 Changed 9 years ago by itschytoo

And another example of a train station.

comment:5 Changed 9 years ago by steve8@…

Done for ways. Will have to revisit for node

comment:6 Changed 9 years ago by Bob

Is there a regression? highway=platform renders but railway=platform stopped rendering two or three weeks ago.

comment:7 Changed 9 years ago by Ldp

railway=platform (as way) regression located and fixed in r17043. Should be back after the next deploy.

comment:8 Changed 9 years ago by lakeyboy

Although way platforms are rendered on Mapnik, area platforms (area=yes) are yet to be coded to render at all.

comment:9 Changed 9 years ago by neutron

In addition we suggest that platform numbers were rendered from "ref" tag. E.g. see here: Platform #4. The number could be rendered the same way as for the highways refs.

comment:10 Changed 8 years ago by steve8@…

  • Owner changed from steve8@… to mapnik-team@…

comment:11 Changed 8 years ago by David Paleino

Hello,
any progress on this issue?

David

comment:12 Changed 8 years ago by David Paleino

#2529 and #2593 have been marked as duplicate of this.

comment:13 Changed 8 years ago by David Paleino

Hello,
I'm attaching a patch which hopefully fixes the problem. It's my first time editing an osm.xml, so I might have done something wrong. Please feel free to correct me and, in case, flame me hard :)

Kindly,
David

Changed 8 years ago by David Paleino

Add rendering for railway=platform + area=yes

comment:15 Changed 8 years ago by Ldp

Platforms now render for area=yes. r22272

comment:16 Changed 8 years ago by Ldp

  • Resolution set to fixed
  • Status changed from new to closed

Deployed some time ago.

Note: See TracTickets for help on using tickets.