Opened 10 years ago

Closed 10 years ago

#1578 closed defect (invalid)

Inconsistent rendering of "tagged" cycleways

Reported by: Jonas Häggqvist Owned by: osm@…
Priority: minor Milestone:
Component: osmarender Version:
Keywords: Cc:

Description

Osmarender seems to render cycleways inconsistently when they exist as a tag on a regular road (highway=secondary, cycleway=track).

For tertiary roads, the cycleway shows up, but for secondary roads they don't. I don't know where or how to look for other combinations, but maybe that needs investigating as well.

An example can be seen here: http://openstreetmap.org/?lat=55.8422&lon=9.82163&zoom=17&layers=0B00FTF

The tertiary road gets rendered with an indication that a cycleway exists, while the secondary road to the left doesn't, even though they're tagged similarly. This doesn't seem like it's intended behaviour.

I've opened a related ticket against mapnik, which contains a bit more background info: http://trac.openstreetmap.org/ticket/1577

Change History (1)

comment:1 Changed 10 years ago by Jonas Häggqvist

Resolution: invalid
Status: newclosed

Looks like the map was just updating slowly. Things looks correct now (or it's been fixed, I guess).

Note: See TracTickets for help on using tickets.