Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1605 closed defect (fixed)

API should be modified to have better access to GPX data

Reported by: stoecker Owned by: tom@…
Priority: major Milestone:
Component: api Version:
Keywords: Cc:

Description

JOSM uses the GPX point download API and has lots of problems with it:

  • No method to decide whether points are connected or not (track data is lost)
  • track data with equal time stamps is intermixed and there is no way to separate them
  • point order is reversed (e.g. http://josm.openstreetmap.de/ticket/1555)

The API should support a much better method to access that data which solves all these problems.
Best would be to pass data as individual track segments.

Change History (6)

comment:1 Changed 6 years ago by tom@…

Much of this is deliberate, to preserve the privacy/anonymity of the data.

comment:2 Changed 6 years ago by openstreetmap@…

This means we have first class users (Potlatch) and second class users (API)?

comment:3 Changed 6 years ago by tom@…

I am not responsible for the fact that the Potlatch author decided to sneak round these restrictions, although I probably am culpable for deploying them without insisting on changes.

comment:4 Changed 6 years ago by xeen

So it's actually not a bug in JOSM but Potlatch? If it's about privacy JOSM's "track guessing" is probably too much already. Clarification would be great, so we can support the actual intention.

comment:5 Changed 6 years ago by openstreetmap@…

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r17044

comment:6 Changed 6 years ago by cyron@…

The question is how it is a privacy problem to serve points in it's order (as ways) if there is no connection to a user, and ... it would be nice to ask a user questions to tracks ...

So maybe it should be selectable for users if the tracks should be published under a pseudonym or with anonymous like this.

Thats one of the major reasons why I doesn't upload gps tracks, because nobody knows how the track was created, like I walk along the road on the sidewalk or something like this, and the next user use it for the center line of the street.

Note: See TracTickets for help on using tickets.