Opened 10 years ago

Closed 9 years ago

#1623 closed defect (worksforme)

Mapnik rendering problem k=wood v=mixed

Reported by: 2longbow@… Owned by: steve8@…
Priority: major Milestone: OSM 0.5
Component: mapnik Version:
Keywords: landuse forest k=wood v=mixed, fails to render Cc:

Description

The mapfeatures page on OSM wiki gives additional key/value sets for landuse forest, e.g.
wood=mixed etc. It appears that when additional values are added to landuse forest, the green area fails to render on the Mapnik stylesheet. I noticed something similar to happen on landuse=residential. When the additional value name=Waldgirmes (to name the residential area) is set, the grey residential area fails to render. After removing the additional values (wood, name) the areas render fine.

Thank you for looking into it.
Longbow4u

Change History (3)

comment:1 Changed 10 years ago by steve8@…

Can you add a permalink please?

comment:2 Changed 10 years ago by 2longbow@…

The Forest area north of Alten-Buseck and north of the motorway. Another user had added k=wood v=mixed. The area did not render. Then I removed this value set, now the landuse=forest area is properly rendered.
Permalink follows:

http://www.openstreetmap.org/?lat=50.6411&lon=8.7897&zoom=13&layers=B000FTF

Perhaps you need to add again this valueset to repeat this behavior.
Thank you,
Longbow4u

comment:3 Changed 9 years ago by Ldp

  • Resolution set to worksforme
  • Status changed from new to closed

It makes no difference to the current stylesheet whether there is a wood=* tag on the forest. You could try adding it again.

Are you sure there was no space in the landuse, like "landuse=forest " ?

Note: See TracTickets for help on using tickets.