Opened 10 years ago

Closed 10 years ago

#1626 closed defect (fixed)

API fails downloading the Island of Guam

Reported by: Craig Harris Owned by: Tom Hughes
Priority: major Milestone:
Component: api Version:
Keywords: Cc:

Description

curl http://www.openstreetmap.org/api/0.5/ma . 3428748554

<!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.01 TransitionalEN"

"http://www.w3.org/TR/html4/loose.dtd">

<html> <body>

<h1>File not found</h1> <p>Change this error message for pages not found in public/404.html</p>

</body> </html>curl: (6) Could not resolve host: à; Host not found curl: (6) Could not resolve host: 3428748554; Host not found

Change History (4)

comment:1 Changed 10 years ago by Tom Hughes

Resolution: invalid
Status: newclosed

Your URL appears to be completely bogus, which is the cause of your problem.

What has happened is that curl has tried to download http://www.openstreetmap.org/api/0.5/ma which is not a valid URL so has produced a 404 response.

It has then tried to download 3428748554 which it seems to have interpreted as a hostname (presumably it decided to treat it as http://3428748554/) which is couldn't resolve.

comment:2 Changed 10 years ago by Craig Harris

Resolution: invalid
Status: closedreopened

Sorry, I pasted the wrong URL..

When I view the map at

http://www.openstreetmap.org/?lat=13.495&lon=144.832&zoom=10&layers=B000FTF

I selected a small area and with an export XML, it will return "500 - Internal Server Error"

http://api.openstreetmap.org/api/0.5/map?bbox=144.8161,13.4568,144.8909,13.5493

Curl returns the same error.

For other areas for Guam, it can be selected.


If I use JOSM, and select the whole region, I get the following error...

Server returned internal error. Try a reduced area or retry after waiting some time.

comment:4 Changed 10 years ago by Craig Harris

Resolution: fixed
Status: reopenedclosed

Downloaded smaller sections for a work around.

Note: See TracTickets for help on using tickets.