Opened 10 years ago

Closed 9 years ago

#1665 closed defect (duplicate)

Rendering of highway=turning_circle is distracting

Reported by: elyk Owned by: mapnik-team@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

At zoom 15+ where highway=turning_circle is rendered, the large gray turning_circle outline distracts from the roads, particularly the road names.

Example: http://www.openstreetmap.org/?lat=38.89647&lon=-94.70019&zoom=15&layers=B000FTF

Osmarender draws a smaller circle on top so that the turning_circle outline is the same width as the road outline.

Attachments (1)

turning_circles.zip (3.4 KB) - added by tylerritchie 9 years ago.
zip containing pngs of turning circles

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by tylerritchie

Attachment: turning_circles.zip added

zip containing pngs of turning circles

comment:1 Changed 9 years ago by tylerritchie

It doesn't look like there are the proper symbols in the repository to make it look correct (namely a gray and a white), so I'm including images replacing and corresponding to the different sizes in the repository already

the rendering rules would use turning_circle.15.png followed--after the roads--by turning_circle.13t.png (I used t for "top")

I've not changed the rendering rules locally yet to test it out, when I do, I'll post a diff unless someone beats me to it. I'm also experimenting with getting turning circles rendered without using symbols..

comment:2 Changed 9 years ago by Ldp

Owner: changed from steve8@… to mapnik-team@…

comment:3 Changed 9 years ago by alexrudd0@…

Resolution: duplicate
Status: newclosed

Duplicate of 1424

Note: See TracTickets for help on using tickets.