Opened 9 years ago

Closed 9 years ago

#1683 closed defect (wontfix)

osmosis leaves in action="delete" elements in JOSM .osm files

Reported by: Harry Wood Owned by: brett@…
Priority: minor Milestone: OSM 0.5
Component: osmosis Version:
Keywords: Cc:

Description

A .osm file saved from JOSM can include elements with action="delete" set on them. It represents a delete which hasn't been 'uploaded' yet. I've just updated the example here to illustrate this http://wiki.openstreetmap.org/wiki/JOSM_file_format

Currently if you run that example through Osmosis it just leaves in the node which has action="delete" set. A more expected behaviour would be to drop the element as osmosis flattens the changes.

Change History (1)

comment:1 Changed 9 years ago by brett@…

  • Resolution set to wontfix
  • Status changed from new to closed

Osmosis is not fully compatible with JOSM files. JOSM allows changes to be represented in the OSM file using the action attribute. Osmosis does not support the action attribute because it uses the alternative OSM Change format (ie. osc files) to achieve the same thing.
I'd rather not add Osmosis support for additional attributes that it doesn't require. It adds additional complexity that must be maintained.

Note: See TracTickets for help on using tickets.