Opened 10 years ago

Closed 10 years ago

#1715 closed defect (fixed)

nodes fetched by relations are incomplete and not completed by "download more"

Reported by: osm6150856065 Owned by: cbro@…
Priority: minor Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

when a node is fetched as a consequence of "Resolve all relations", its tags are not fetched at all (which might be a bug by itself unless intended). if a thus fetched node is scrolled to and "Download more" is used, the tags are not fetched either.

steps to reproduce:

  • choose a relation, eg a route=tram on 48.214296/16.305575 (make sure you don't see more than a kilometer)
  • "Download" with "Resolve all relations"
  • zoom to 48.244167/16.379632, look at node_294453907. neither name nor railway=rail_stop will show in its tag details
  • "Download more"

tested with version 0.13.1 built from debian

Change History (1)

comment:1 Changed 10 years ago by Chris Browet

Resolution: fixed
Status: newclosed

(In [14680]) FIX : API 0.6 fixes FIX : Nodes fetched by relations are incomplete and not completed by "download more" (fixes #1715)

Note: See TracTickets for help on using tickets.