Opened 10 years ago

Closed 6 years ago

#1735 closed defect (wontfix)

Map download does not return all relevant ways

Reported by: stuuf Owned by: rails-dev@…
Priority: major Milestone:
Component: api Version:
Keywords: Cc:

Description

This is a rather large problem with some annoying rendering implications that I noticed many months ago, and since it's apparently been overlooked in the recent database/api upgrade I figured I'd report it here.

When downloading map data within a bounding box, the algorithm used seems to be something like this:

  1. select all nodes within the box
  2. select all ways that contain nodes from 1
  3. select any additional nodes contained by ways in 2

If you know enough about geometry, you should realize that this does NOT include the complete definition of a line segment intersecting a bounding box. Consider this situation:

  +----------+
* |          |
 \|          |
  X          |
  |\         |
  | \        |
  +--X-------+
      \
       \
        * 

The line segment obviously crosses through the box, but since neither of its endpoints (*) fall within the box the API won't select it.

Mapnik seems to use PostGIS's geometry operators to search so I don't think it's affected by this, but Osmarender will often miss ways that cross through tiles but don't have any nodes in that tile. Ways like US county lines, which usually have very long straight segments that cover many tiles, only get rendered on the corners, with spaces in between.

I've confirmed this problem still exists in api 0.6 using JOSM

Change History (2)

comment:1 Changed 8 years ago by Tom Hughes

Owner: changed from Tom Hughes to rails-dev@…

comment:2 Changed 6 years ago by iandees

Resolution: wontfix
Status: newclosed

Cleaning old tickets.

Note: See TracTickets for help on using tickets.