Opened 9 years ago

Closed 7 years ago

#1745 closed defect (fixed)

Problem editing ways with Relations

Reported by: drlizau Owned by: tom@…
Priority: major Milestone: OSM 0.6
Component: api Version:
Keywords: split way relations Cc:

Description

I'm trying to split ways with relations and striking errors. JOSM does not tell me what the error was but Potlatch does
"An unusual error happened (in 'putrelation' 88033). The server said:
Precondition failed: Cannot update relation 88033: data or member data is
invalid."

Example way 31766321, which is an admin boundary and part of 2 mulitpolygons

Now, it is not simple. Some of these ways will split and some will not. One I tried to split in Potlatch which gave me an error was split when I downloaded again into JOSM. The way given above just hung Potlatch in upload and did not split.

Change History (4)

comment:1 Changed 9 years ago by drlizau

Next experiment : Merkaartor will allow me to split that way, provided I tell it to ignore the error condition. Checking the data shows that on one of the two ways created, one has its two memberships,

member of multipolygon "Oxley"
member of mulitpolygon "Keri Keri"

and one has now dropped one membership

member of multipolygon "Keri Keri"

attempting to add this way to multipolygon "Oxley" fails
"transfer aborted due to error condition"

comment:2 Changed 9 years ago by tom@…

Can you clarify exactly what you are complaining about? Are you suggesting that the server is wrong to reject these changes? or that one (or more) clients are generating invalid changesets? If it's the latter then which clients exactly?

comment:3 Changed 9 years ago by drlizau

With 3 different clients, I cannot edit a way with 2 relations. The attempt to save is rejected by the server.
If it was one client, i would be concerned about the client, so I tried 3 available to me.
reported also from Au tonight

I'm working on 2 relations like this on KI that sound like they are
having the same kind of issue. ANY edit of any form to the relation
would cause an error - EXCEPT deleting I eventually tried on one of
them. So I've just kept a copy of all the details about the relation,
deleted the old one and created an identical one that matched the
original, THEN I could edit the new one without any trouble.

comment:4 Changed 7 years ago by TomH

  • Resolution set to fixed
  • Status changed from new to closed

This sounds like a duplicate of #1736 in that the error message lacks details. That is now solved and the messages should provide enough detail to properly diagnose and fix the underlying problem.

Note: See TracTickets for help on using tickets.