Opened 10 years ago

Closed 10 years ago

#1754 closed defect (invalid)

JOSM 1555 error

Reported by: val42k@… Owned by: Tom Hughes
Priority: minor Milestone: OSM 0.6
Component: api Version: 1.0
Keywords: Cc:

Description

Since the protocol change, I haven't been able to upload any changes with either 1515 or 1529, so I downloaded the latest JOSM. (See JOSM discussion page for details.) When attempting to upload a change with 1555 (1 way modify, 1 way delete, 16 nodes delete) I get the following error report:

Path: trunk URL: http://josm.openstreetmap.de/svn/trunk Repository Root: http://josm.openstreetmap.de/svn Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b Revision: 1555 Node Kind: directory Last Changed Author: framm Last Changed Rev: 1555 Last Changed Date: 2009-04-25 01:41:22 +0200 (Sat, 25 Apr 2009)

Java version: 1.6.0_0 Plugins: lakewalker;openvisible;wmsplugin Plugin lakewalker Version: 14015 Plugin openvisible Version: 14233 Plugin wmsplugin Version: 14120

java.lang.RuntimeException?: java.lang.NullPointerException?

at org.openstreetmap.josm.gui.PleaseWaitRunnable?$4.run(PleaseWaitRunnable?.java:119) at java.awt.event.InvocationEvent?.dispatch(InvocationEvent?.java:226) at java.awt.EventQueue?.dispatchEvent(EventQueue?.java:602) at java.awt.EventDispatchThread?.pumpOneEventForFilters(EventDispatchThread?.java:275) at java.awt.EventDispatchThread?.pumpEventsForFilter(EventDispatchThread?.java:200) at java.awt.EventDispatchThread?.pumpEventsForHierarchy(EventDispatchThread?.java:190) at java.awt.EventDispatchThread?.pumpEvents(EventDispatchThread?.java:185) at java.awt.EventDispatchThread?.pumpEvents(EventDispatchThread?.java:177) at java.awt.EventDispatchThread?.run(EventDispatchThread?.java:138)

Caused by: java.lang.NullPointerException?

at org.openstreetmap.josm.io.OsmApi?.modifyPrimitive(OsmApi?.java:256) at org.openstreetmap.josm.io.OsmServerWriter?.makeApiRequest(OsmServerWriter?.java:122) at org.openstreetmap.josm.io.OsmServerWriter?.uploadOsm(OsmServerWriter?.java:100) at org.openstreetmap.josm.actions.UploadAction?$2.realRun(UploadAction?.java:180) at org.openstreetmap.josm.gui.PleaseWaitRunnable?.run(PleaseWaitRunnable?.java:101) at java.util.concurrent.ThreadPoolExecutor?.runWorker(ThreadPoolExecutor?.java:1110) at java.util.concurrent.ThreadPoolExecutor?$Worker.run(ThreadPoolExecutor?.java:603) at java.lang.Thread.run(Thread.java:636)

Attachments (1)

Ogden.osm.gz (134.3 KB) - added by val42k@… 10 years ago.
This is the OSM file w/changes that I was trying to upload.

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by val42k@…

Attachment: Ogden.osm.gz added

This is the OSM file w/changes that I was trying to upload.

comment:1 Changed 10 years ago by Tom Hughes

Resolution: invalid
Status: newclosed

JOSM problems need to be reported in the JOSM bug tracker at http://josm.openstreetmap.de/

Note: See TracTickets for help on using tickets.