Opened 10 years ago

Closed 9 years ago

#1758 closed enhancement (fixed)

Create JDK 1.5 compatible build for API 0.6.

Reported by: bretth Owned by: bretth
Priority: major Milestone:
Component: osmosis Version:
Keywords: Cc:

Description

Osmosis require a minimum of JDK1.6. However there are still some PowerPC MAC users out there who only have access to JDK1.5. It is possible to create a JDK1.5 compatible Osmosis build by removing the bounding polygon task and eliminating any 1.6 specific function calls such as String.isEmpty.

Change History (5)

comment:1 Changed 10 years ago by bretth

Type: defectenhancement

Changed it to an enhancement rather than a defect.

comment:2 Changed 10 years ago by Alek Chmyr

Owner: changed from bretth to Alek Chmyr
Status: newassigned

I'm planing to update current trunk version for 1.5 jdk, also update 1.6 related warnings like @override interface method.

comment:3 Changed 10 years ago by Alek Chmyr

Owner: changed from Alek Chmyr to bretth@…
Status: assignednew

Created tag in osmosis project: api0.6-java1.5. there put files verified for 1.5. I ran tests and they were successfully passed.

Please verify

comment:4 Changed 10 years ago by Alek Chmyr

Owner: changed from bretth@… to bretth

comment:5 Changed 9 years ago by bretth

Resolution: fixed
Status: newclosed

Build was released back in May last year and no problems have been reported.

Note: See TracTickets for help on using tickets.