Opened 9 years ago

Closed 7 years ago

#1795 closed defect (fixed)

natural=bay not rendered

Reported by: PHerison Owned by: osm@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: natural bay render Cc:

Description

Feature natural=bay won't be rendered:
http://www.openstreetmap.org/browse/way/34117071

Attachments (1)

Change History (9)

comment:1 Changed 9 years ago by bob@…

  • Resolution set to invalid
  • Status changed from new to closed

I don't think that data makes sense, the bay area is part of the lake and should as such be in the same way.

comment:2 Changed 8 years ago by aharvey

I would like to reopen this issue for both osmarender and mapnik (I'm not sure how to tag this issue for the mapnik compenent as well). The wiki says "A bay is an area of water", the wiki says that natural=bay is appliciable to ways, so if someone traces out the area of the bay, I think it should be rendered just like natural=water.

Something like my attatched diff is my suggestion for mapnik, although someone with more experience should double check it. Sorry I don't know how osmarender works.

comment:3 Changed 8 years ago by aharvey

  • Component changed from osmarender to mapnik
  • Priority changed from major to minor
  • Resolution invalid deleted
  • Status changed from closed to reopened

reopening and switching to mapnik (even though the issue is also present with osmarender)

comment:4 Changed 7 years ago by Federico Explorador

  • Summary changed from natual=bay not rendered to natural=bay not rendered

Hi,
I support this request.
In addition, I suggest that the name given to a bay should be rendered starting zoom level 9 with the name as big as a town. Actually, the renderers shows up the name only at zoom level 15.

comment:5 follow-up: Changed 7 years ago by aharvey

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:6 in reply to: ↑ 5 ; follow-up: Changed 7 years ago by Ldp

Replying to aharvey:

I try to only close these once the stylesheet has been deployed on osm.org.

comment:7 in reply to: ↑ 6 Changed 7 years ago by aharvey

  • Resolution fixed deleted
  • Status changed from closed to reopened

Replying to Ldp:

Replying to aharvey:

I try to only close these once the stylesheet has been deployed on osm.org.

Oh sorry, good idea.

It was funny actually because I was thinking about committing this very change that you made only a few days before you did. Thank you.

comment:8 Changed 7 years ago by Ldp

  • Resolution set to fixed
  • Status changed from reopened to closed

(In r25668)

Note: See TracTickets for help on using tickets.