Opened 10 years ago

Closed 9 years ago

#1814 closed defect (fixed)

can't upload modifications in files downloaded from XAPI

Reported by: petr.dlouhy@… Owned by: 80n80n@…
Priority: major Milestone:
Component: xapi Version:
Keywords: Cc:

Description

When I download something from XAPI, and make some modifications, I can't upload them back. This is probably due missing version numbers in the file.

See this bug in JOSM track, for further information.

Change History (4)

comment:1 Changed 10 years ago by Tom Hughes

That's a feature, not a bug.

To be honest I'm not quite clear what you're complaining about here, or what you want us to do...

Are you waying you want the API to allow you to upload without specifying the version (not going to happen) or that you want XAPI to return versions for pre-0.6 objects (not going to happen until the XAPI database is reloaded from scratch)?

Of course if you'd selected an appropriate component when entering the bug we might have a better idea what you wanted...

comment:2 Changed 10 years ago by petr.dlouhy@…

Component: adminxapi
Owner: changed from Tom Hughes to 80n80n@…

Of course, the component had to be xapi, sorry for that.

I want to edit files downloaded from XAPI (e.g. now I want to add tag operator=cz:KČT to all czech bicycle routes), and upload my changes back to OSM, but it is not working. That's the bug, I am reporting.

According to discussion under the bug I linked, it is not bug in JOSM but in XAPI. It probably doesn't version numbers for the objects.

comment:3 Changed 10 years ago by Thomas Wood

80n noted on the mailing list recently that only objects that have been edited will gain a version number in xapi. That is until a planet dump is imported from afresh.

comment:4 Changed 9 years ago by petr.dlouhy@…

Resolution: fixed
Status: newclosed

I think, this could be closed. I didn't face this problems for long time.

Note: See TracTickets for help on using tickets.