Opened 10 years ago

Closed 10 years ago

#1850 closed defect (duplicate)

Potlatch again didn't save

Reported by: Gibuld Owned by: richard@…
Priority: major Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

Working offline with the new Potlatch seemed to work saver than before. Now I have to discover it actually isn’t. Today I entered 35 tracks converted and unlocked them connected them to other streets and defined them. Several times I saved my work. One time it didn’t finish saving. I aborted saving and repeated it. This save then was prompted correctly within seconds. The last save before finishing also seemed to be correct. Nothing is correct. Great part of my work is corrupted ! Instead of finished streets I have a lot of green points. I don’t know where they come from.

Obviously this terrible tool handles aborted saves like correct saves and doesn’t care about the actually unsaved objects when repeating saving.

Attachments (1)

Potloatch_090523.jpg (152.9 KB) - added by Gibuld 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by Gibuld

Attachment: Potloatch_090523.jpg added

comment:1 Changed 10 years ago by Tom Hughes

Component: adminpotlatch (flash editor)
Owner: changed from Tom Hughes to richard@…

comment:2 Changed 10 years ago by Richard

Resolution: fixed
Status: newclosed

This should have been fixed last night in r15192 (now deployed I think). If you can reproduce the problem now please let me know.

But please, be a bit more civil than resorting to insults like "obviously this terrible tool" I am hardly going to be inclined to help you. Come on, we're all volunteers doing the best we can. I am hardly sitting here writing code that intentionally destroys your work, though with language like that I could be tempted to.

comment:3 in reply to:  2 Changed 10 years ago by Gibuld

Resolution: fixed
Status: closedreopened

Replying to Richard:

This should have been fixed last night in r15192 (now deployed I think). If you can reproduce the problem now please let me know.

But please, be a bit more civil than resorting to insults like "obviously this terrible tool" I am hardly going to be inclined to help you. Come on, we're all volunteers doing the best we can. I am hardly sitting here writing code that intentionally destroys your work, though with language like that I could be tempted to.

comment:4 Changed 10 years ago by Gibuld

Richard, Please be aware that I didn’t intend to offend you. I only wanted to describe my feelings when working with Potlatch. The situation today is as follows: Working with Potlatch offline is good, as long as it can connect to the server when saving. When the connection fails, then Potlatch is hanging for ever and the exclamation triangle is blinking. After aborting the pending save, I then can press the triangle with the result “connection to server lost” or so. Repeating the save then leads to “nothing to save”. And this is the point: Connections to the server may fail and can be repeated – no problem. But what should not happen is, that Potlatch then forgets what had to be saved. Especially: Potlach still displays my work, but Potlatch is unable to save it again. Isn’t this terrible for a user who also works as volunteer ? Two subsequent saves this morning behaved this way. Logging in again then proved, that nothing at all had been saved. Best regards, Gibuld

comment:5 Changed 10 years ago by Richard

Resolution: duplicate
Status: reopenedclosed

Ah, ok, if this is a "doesn't save after warning triangle" issue then it's now a duplicate of #1864 (or #1864 is a duplicate of this, or whatever). :)

I'm on deadline in the day job at the moment so haven't got any spare minutes to look at it - hopefully next week.

In the meantime it does say in the help to save often in case of server problems. It _really_ _really_ means it!

Note: See TracTickets for help on using tickets.