Opened 10 years ago

Closed 8 years ago

#1861 closed defect (fixed)

Changesets without a bounding box aren't shown on users changeset list.

Reported by: Teemu Koskinen Owned by: zerebubuth@…
Priority: minor Milestone:
Component: website Version:
Keywords: Cc:

Description (last modified by Tom Hughes)

Changesets without a bounding box are not visible on the users edit history page.

eg. an edit made by me to just one relation: http://www.openstreetmap.org/browse/changeset/1321859 doesn't show on my list: http://www.openstreetmap.org/user/Daeron/edits

Change History (9)

comment:1 Changed 10 years ago by Tom Hughes

Description: modified (diff)

I believe this was a deliberate design decision, although your case is an interesting one as it shows that it is possible to have a non-empty changeset without a bounding box and I was told that the reasoning was that we didn't want to bother showing empty changesets.

comment:2 Changed 10 years ago by zere

Resolution: fixed
Status: newclosed

(In [15237]) Better testing of bbox handling in relations. Maybe fixes #1861, but wasn't able to reproduce the exact case. Fixed bug handling bboxes where element is repeated in relation.

comment:3 Changed 10 years ago by Matt

Resolution: fixed
Status: closedreopened

resolution set to *maybe* fixed.

comment:4 Changed 10 years ago by Tom Hughes

Oh I see, I wasn't aware that we tried to update bboxes for relation changes. I thought we had just wimped out on that.

I'll deploy the change in a minute, but obviously this won't change the existing changeset so it is going to be hard to know if your change has actually fixed this or not...

comment:5 Changed 10 years ago by Teemu Koskinen

Any news on this?

The problem occurs when only the ordering of a relation is changed. If members are added/removed, I think the bounding box is calculated for those objects and the problem doesn't show up.

I guess it would be pretty hard to decide what members were moved, eg. was it that one member was moved three places up, three members one place down, or both?

So what should the bounding box be for a just ordering change? All members could be too much if the relation is too big...

comment:6 Changed 8 years ago by ToeBee

This bug appears to still exist.

Here is a changeset that only affected relations (deleting them): http://www.openstreetmap.org/browse/changeset/7585986

It does not show up under the user's list of edits: http://www.openstreetmap.org/user/hpawlow/edits

comment:7 Changed 8 years ago by Tom Hughes

Owner: changed from Tom Hughes to zerebubuth@…
Status: reopenedassigned

comment:8 Changed 8 years ago by rickmastfan67

It seems that this might be fixed now. I was just looking at the edit list of NE2, and an old changeset of his that didn't have a bounding box now shows up on his main edit list which I mentioned in #3837 which was closed as a duplicate of this ticket.

http://www.openstreetmap.org/user/NE2/edits Changeset: #8473084

I will not close it just yet, but I just wanted to put this out there.

comment:9 Changed 8 years ago by Teemu Koskinen

Resolution: fixed
Status: assignedclosed

Yes, seems to be fixed, probably when the list was changed to include the map. My original example is shown on my list (currently on page 320.. ;-) ), as is the one said by ToeBee?.

Note: See TracTickets for help on using tickets.