Opened 10 years ago

Closed 10 years ago

#1864 closed defect (fixed)

Problem with upload on edit with save Potlatch v1.0

Reported by: daveemtb Owned by: Richard
Priority: critical Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

I've just lost more than an hour's work due to this bug :'( There are two different behaviours with the same effect seen this morning:

1) When you try to save, the upload box pops up but it never finished. Eventually you see the red triangle in the bottom left. After cancelling the upload (cos nothing's happened in a very long time!) Clicking on the red triangle, and clicking retry, then clicking save again, it flashed up "deleting POIs" (I didn't delete any POIs!) and then says that it's uploaded ok. Problem is, it hasn't uploaded anything. Clearing the cache and reloading the edit page shows this. DOH!

2) When you try to save, again, the upload box appears but never finishes. Eventually you cancel and try again, and it says there's nothing to upload. Again, nothing has been uploaded.

I understand these problems are probably related to heavy server load, but we need a better way of dealing with this.

Change History (2)

comment:1 Changed 10 years ago by Richard

Owner: changed from richard@… to Richard
Status: newassigned

Hm. Certainly a server load issue at heart, but maybe the ways are still marked internally as "currently uploading" which is stopping them from being reuploaded a second time? I'll check.

comment:2 Changed 10 years ago by richard

Resolution: fixed
Status: assignedclosed

(In [15276]) improve error handling when connection fails; closes #1864 and #1871

Note: See TracTickets for help on using tickets.