Opened 9 years ago

Closed 4 years ago

#1873 closed defect (duplicate)

[roads] highway=pedestrian does not render correctly (layer issues).

Reported by: lakeyboy Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

If I am correct, the issue with highway=pedestrian used with area=yes ignoring layers and causing it to render over the top of buildings set on higher layers has been fixed. There looks to still be a bug where despite highway=pedestrian being set on a higher layer, other highway= and railway= ways are still rendered over the top of it when they should be rendered under, in the same fashion as the Osmarender does it. An example can be found here: http://www.openstreetmap.org/?lat=-37.81716&lon=144.9499&zoom=17&layers=B000FFTF Thanks.

Change History (6)

comment:1 Changed 9 years ago by alex.hunziker@…

This is also a problem for http://www.openstreetmap.org/browse/way/24022047/history for example: the church doesn't get rendered.

comment:2 Changed 9 years ago by steve8@…

  • Owner changed from steve8@… to mapnik-team@…

comment:3 Changed 9 years ago by wicking

A duplicate of this one could be #1971, I think.

comment:4 Changed 5 years ago by javbw

The pedestrian tag is ignoring layers when set as a way too - This isn't just for areas. I am making a park with gates over the pedestrian paths. Setting the way to highway=pedestrian layer=1 renders through the gate, building=roof layer=2.

I'm making some pedestrian areas, and it renders over everything too - I'm having to make it multipolygon to keep features from being overdrawn. http://www.openstreetmap.org/#map=19/35.73258/139.74781

comment:5 Changed 5 years ago by math1985

  • Summary changed from highway=pedestrian does not render correctly (layer issues). to [roads] highway=pedestrian does not render correctly (layer issues).

comment:6 Changed 4 years ago by math1985

  • Resolution set to duplicate
  • Status changed from new to closed

This is now being discussed on Github: https://github.com/gravitystorm/openstreetmap-carto/issues/527

Therefore, I will close the issue here.

Note: See TracTickets for help on using tickets.