Opened 9 years ago

Closed 9 years ago

#1883 closed defect (invalid)

No map display

Reported by: jean.cayron@… Owned by: cbro@…
Priority: critical Milestone: OSM 0.6
Component: merkaartor Version:
Keywords: map display Cc: openstreetmap@…

Description

Since an update around start of may 2008, Merkaartor doesn't show my map anymore (see attachment). If you zoom or move, nothing change. Allways this white screen with the black line.

What it tried without succes:

  • Two or three updates didn't change anything (I'm now with 0.13.2)
  • I removed the directory ~/.config/BartVanhauwaert/ and its content.
  • I removed ~/.QMapControlCache/
  • I suppressed and reinstalled Merkaartor.

I use Merkaartor on openSUSE 11.1 x86_64 from the repository Application:Geo
My Qt version 4.4.3.

I tried to install Windows version with Wine and everything is fine (except it looks ugly ;-) ).

Cheers for your help, I cannot use this great software right now, it blocks me.

Attachments (1)

merkaartor0-13-2.png (76.1 KB) - added by jean.cayron@… 9 years ago.
Screenshot of the problem

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by jean.cayron@…

Screenshot of the problem

comment:1 Changed 9 years ago by Koying

Could you try by deactivating "Shown downloaded area" in the view menu, please.

comment:2 Changed 9 years ago by jean.cayron@…

I deactivated it: the only change is that the redpoint grid disapeared. Nothing else apeared after some try of zooming to layer and so on.

Removing "Show scale" made the black line on left bottom corner disapear.

On the item "set projection" the sub menu is empty. Is that normal?

comment:3 Changed 9 years ago by Herbert3

In the "initialize" method of EditPaintStyle? there is a "#ifndef NDEBUG" which should not be there (?)

comment:4 Changed 9 years ago by Koying

Indeed... But it's unrelated to this problem as it is in svn only and the reporter stated that he uses 0.13.2

comment:5 Changed 9 years ago by jean.cayron@…

  • Cc openstreetmap@… added

I think we've found the problem, there is no projection set. In the menu View>Set projection, the child menu is empty. Same in Preferences.

Probably a packaging error in the openSUSE 11.1 Application:Geo repository. Packager contacted.

It's a problem with PROJ=1 in the qmake commandline or in "Config.pri".

comment:6 Changed 9 years ago by jean.cayron@…

  • Resolution set to fixed
  • Status changed from new to closed

Bug fixed.

Packager compiled 0.13.2 with "PROJ=1" enabled, which causes (and probably others) problems.

The packager for Application:Geo repo from openSUSE recompiled and packaged it.

Works fine.

comment:7 Changed 9 years ago by bernd@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

The bug should be fixed - closing it because building with PROJ=0 works is probably not the best solution...

comment:8 Changed 9 years ago by Koying

  • Resolution set to invalid
  • Status changed from reopened to closed

Who asked anyone to use the PROJ parameter?
As said on the list, it was experimental and not meant for release.

Just forget about it completely. Has disappeared in 0.14 anyway. point.

Note: See TracTickets for help on using tickets.