Opened 10 years ago

Closed 10 years ago

#1896 closed defect (invalid)

railsport uses time_ago_in_words() which can't be translated

Reported by: avar Owned by: Tom Hughes
Priority: major Milestone:
Component: website Version:
Keywords: i18n Cc:

Description

E.g.:

%= t 'user.view.mapper since' %></b><%= l @this_user.creation_time %> <%= t 'user.view.ago', :time_in_words_ago => time_ago_in_words(@this_user.creation_time) %>

Change History (2)

comment:1 Changed 10 years ago by Tom Hughes

The internal rails stuff like that internationalises just fine - we already have translations for many languages from a plugin we added. If I set my language to French for example then I get things like "(environ 23 heures ago)" for that example you gave.

The problem is just that the plugin doesn't have an Icelandic translations ;-)

If you add an is.yml file to vendor/plugins/rails-i18n/locale then you should find it sorts out your problems. If you are feeling generous then you might want to submit it to the upstream authors of that plugin, though I'm struggling right now to find out where Shaun got it from...

comment:2 in reply to:  1 Changed 10 years ago by avar

Resolution: invalid
Status: newclosed

Replying to tom@compton.nu:

The problem is just that the plugin doesn't have an Icelandic translations ;-)

If you add an is.yml file to vendor/plugins/rails-i18n/locale then you should find it sorts out your problems. If you are feeling generous then you might want to submit it to the upstream authors of that plugin, though I'm struggling right now to find out where Shaun got it from...

It's from the rails-i18n repository. I'll submit a translation to upstream.

Closing this as invalid since it's translatable and adding a is.yml file should be done upstream.

Note: See TracTickets for help on using tickets.